Konfigurasi Apache 2.4 up untuk Virtualhost

Misalkan Anda memiliki server web dengan IP 222.222.222.222 dan akan mendaftarkan nama domain domainsaya.com di server tersebut, berikut adalah langkah konfigurasinya :

Setting DNS ditempat Anda mendaftarkan domain sehingga nama domain tersebut mengarah ke IP 222.222.222.222. Dengan demikian siapapun di internet ketika akan mencari domainsaya.com akan diarahkan ke IP 222.222.222.222.

Berikutnya tinggal setting di Web server kita, dalam hal ini Apache 2.4. Bagaimana caranya ?

Buatlah sebuah file conf di /etc/apache/site-available/domainsaya.conf. Isilah dengan :

<VirtualHost 222.222.222.222:80>
DocumentRoot /home/domainsaya/public_html
ServerName domainsaya.com
# Other directives here
       <Directory /home/domainsaya/public_html/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>
</VirtualHost>

File konfigurasi domainsaya.conf ini harus memiliki symbolic link di /etc/apache/site-enabled/ agar dapat berfungsi :

ln -s /etc/apache/site-available/domainsaya.conf /etc/apache/site-enable/domainsaya.conf

Kemudian Apache perlu kita reload

#service apache restart

Semoga bermanfaat.

Tambahan :

Apache 2.4.3 telah menambahkan feature keamanan baru yang memungkinkan muncul pesan error “403 forbidden” yang tidak muncul jika menggunakan Apache 2.2.x. Atau bisa juga pesan berupa “client denied by server configuration”.
Fitur ini membutuhkan identitas pengguna untuk mengakses direktori. Fitur ini diaktifkan secara DEFAULT di dalam httpd.conf yang dibuat bersamaan pada saat instalasi Apache pertama kali. Kita dapat melihat aktifnya fitur ini dari directive :

Require all denied

Directive di atas tersebut akan menolak akses dari semua users. Untuk mengubahnya anda dapat saja menghapus directive tersebut, atau menambahkan directive lawannya di directory yang akan Anda buat terbuka akses nya :

Require all granted

diletakkan di :

;
   Order allow,deny
   Allow from all
   # New directive needed in Apache 2.4.3: 
   Require all granted

Leave a Reply

Your email address will not be published.

Captcha Captcha Reload